[S922X] Bee-link GT King

You dont need any injection. Just use remote.conf file in CE. Works good.

Should I remove the Injection? How?
Before that I had the same problem - I can’t shutdown or reboot properly. The screen turns black but the box stays with the green leds and never really turns off or reboots.

What remote.conf should I use?

Here is mine. remote.conf (1.5 KB)

1 Like

Thank you. It’s exactly the same as another one I’ve found here.
I’ve tried it before with no success.

I have two problems:

1 - The box doesn’t shutdown or reboot properly. The screen turns black and disconnects but the box stays with the green leds and never really turns off or reboots.

2 - The remote doesn’t activate the shutdown on kodi.
However if I suspend the box then the leds go red and the remote works to wake it. I don’t know if it also works from a shutdown state because I can’t put the box on such state.

Logs (before the remote.conf but it didn’t change the behaviour):
From Kodi: http://ix.io/24mK
From ssh dmesg | paste : http://ix.io/24mL

I have Stock android rom from beelink, no any bl injection, CE on usb pendrive. With this, the box working good, totally power off, no led light.

From your logs it looks like clean start…
What Android firmware does your box have?
Try to comment decode_type, remotewakeupmask, wol values. They are the same as default one
So you can change only remotewakeup code. Is it correct? Does power button works for shutdown?

I have firmware 906P0.
SN: B922HQ…
I installed CE rev A on SD card because it didn’t boot with rev B.

Before I had the original config.ini with no changes but then I tried everything I’ve read trying to solve the problem.

The power button on remote doesn’t work for shutdown. It only works to resume from the suspend state.
I’m not even trying to solve the remote problem now - first I would like to be able to shutdown/reboot the box properly.
If not I’ll have to educate myself to just suspend the box.

If it doesn’t work for power off then it looks like you have wrong code…
Or use instruction to find correct key How to configure IR remote control
Or
Enable debug mode, press power button, disable debug mode and collect log

With the following keymap file now the power button shutdowns Kodi

# table gtkingboxkeymap, type: NEC
0x8051 KEY_POWER

However the behavior is the same as if I select the option on the UI: The box turns off the screen and the network but the leds are still on (green) and the only way to restart is to turn off the power and then turn on again.

PS: I discovered that if I unmount the emmc file system before shutdown (I’m mounting on startup doing something like this: How to run CoreElec on internal memory eMMC on NG boxes (S905X2, S922X) having full operating Android system too) then when I shutdown the box goes to sleep - I say it goes to sleep and not turns off because the led lights are dark red, not completely off, but perhaps that’s just how it works.
Problem is that with the key map the remote does not wake it.

Resume:

  • I can use the remote to turn off Kodi (using the keymap) or to wake the box (using config.ini), but not both.
  • Box does not shutdown if a mount to emmc exists (I have to automate the umount on shutdown.sh).
  • The box never completely turns the leds light off - they’re red on shutdown? / suspend.

You are using a tool that wasn’t provided by Team CE. Please test your device running from SD or at least use the official tool ceemmc. This isn’t supported on the king but I can guarantee that it’s fully functional.

Sorry but I don’t understand. Which tool am I using that I shouldn’t?

  • Is it possible to shutdown and also wake the box from the remote?
  • When the box shut downs how should the leds be? (The eyes on the skull). Dark red or completely off?

Than you.

If you followed what is discussed in that topic you’re on your own. My eyes stay red.

Oh no, that’s not it, perhaps there’s a misunderstanding - I’m running CE from the SD card isolated from the Android system.
The only thing I picked from that topic is a couple lines of .sh about how to mount the emmc file system so that I could use the storage space. That’s all.

If you also have the “red eyes” then it means it is the expected behavior. Good.

The only thing I’m missing now is how to use the power button on the remote to perform both on and off functions.
– With the keymap if turns off but doesn’t turn on.
– With config.ini it turns on but doesn’t turn off.
– With remote.conf if does nothing.

– Which is your configuration?
I also installed the BL301 but it seems unnecessary.

Thanks!

Ok, sorry. I use BL301 injection but my remote is not the original (it stopped working). Now I use the Khadas vtv remote and just changed the wakeup code on config.ini.

1 Like

Well… it seems that if I have both config.ini and the keymap I can use the power button to turn on and also to turn off the box!!!
I have to test it better tomorrow.
Thanks.

Hi to all, I’m new to the forum but I’m using coreelec on my gtking from a few month .

I started in the nightly channel and all was good until the last update received with the new kernel .
My system goes in bootloop with both 20191213/14 nightly . I have already tried a clean install of coreelec and Android OS in order to avoid plugin issues . If I revert back to old nightly /9.2.1 stable build all is fine .

Firmware 906p0
Coreelec on SD card
Sn 922x

Does anybody faced the same problem ?

I tested a fresh install if the nightly and it worked on my GT-King.

I know that the following will be some dumb questions but ,on which firmware is your gt king ? Are you booting from as card ? If yes did you used the toothpick method the first time ?
I have tried again but after beelink logo I’m getting a black screen and then the beelink logo again in loop. If I revert to the old nighlies everything is working

I didn’t need to use toothpick method but if you’re having problems you should use it. My android version is 906P0 as yours.

I have the same issue. My only working version of nightly is 20191204. Even I get the full image of 20191214 and make fresh install to spare CF or USB storage the CoreELEC won’t boot - bootloop.
This continue after I revert the SYSTEM.img and kernel.img. I have to make a fresh install of 20191204 and bytecopy the partition of COREELEC. After this the CF card is already bootable.