(SOLVED) Netflix Frame Skip Temporary Solution

Since latest WideVine update to version libwidevinecdm.so.4.10.1440.18 some users have problems with frame skipping on high bit-rate scenes. I found out that using previous WideVine version libwidevinecdm.so.4.10.1303.0 solves this problem.
For anyone interested I uploaded both, new and old WV versions here.
Zip is pass protected with easily guessed password :slight_smile:

Scenes to test the difference: “Our Planet” E1 4min-6min and “Kiss Me First” E1 from beginning. On both scenes the bitrate goes over 20 Mbit/s.


Sorry, what is the easily guessed password (seems I’m not so good at finding out :).

1 Like

It’s sholander :wink:

I knew I was naive when asking, but now I feel ashamed :smiley:
I used the uploaded library, but I didn’t get a better frame rate.

Sorry to hear that, did you use the right one named old ? On my N2 on CE 9.0.3 it makes a big difference between new and old.
Did you try above mentioned videos ? How do they work for you ?

Btw, maybe we don’t understand each other, you cannot get better frame rate with “old” libwidevinecdm. It only helps to eliminate frame skip on high bitrate scenes.
For example with “new” version playing "Our Planet” E1 4min-6min scenes I get more than 200 skipped frames, and same sequence played with old version I have only one or two skipped frames


https://drive.google.com/open?id=1aSip5SU1k41L7nVAqRVM0pyp3lBTvYMS .

It gives me such an error, I have searched for a solution but could not find it.
I would be glad if you help.

Best regards…

I cannot see any (relevant) error, as there are lots of them.
Try with a fresh/new install and install ONLY Netflix addon, then see if there is any error.

Btw, what is exactly the problem, you can’t log in, you can’t do something in addon or the video does not play ?

OK, I see. First as suggested before make a fresh installation with default skin and install only Netflix addon. If you then get the same error, collect all logs in .kodi/temp folder and send them to see what is going on.
If it’s an addon error then seek further help here

1 Like


Addon settings reset, the problem was solved.
Thank you for your interest in my friend.

Best regards…

I meant that I overwrote the current libwidevinecdm.so using the one you provide, but could not notice any difference when matching any high-bitrate scenes.

CoreELEC:~/.kodi/userdata/addon_data/script.module.inputstreamhelper/cdm # cp libwidevinecdm.so.old libwidevinecdm.so
CoreELEC:~/.kodi/userdata/addon_data/script.module.inputstreamhelper/cdm # ll
-sh: ll: not found
CoreELEC:~/.kodi/userdata/addon_data/script.module.inputstreamhelper/cdm # ls -alrt
total 20140
-rw-r–r-- 1 root root 146462 Aug 16 20:17 widevine_config.json
drwxr-xr-x 3 root root 1024 Sep 6 13:53 …
-rwxr–r-- 1 root root 6821832 Sep 18 22:03 libwidevinecdm.so.old
-rwxr–r-- 1 root root 6829784 Sep 18 22:04 libwidevinecdm.so.nex
-rwxr–r-- 1 root root 6821832 Sep 18 22:04 libwidevinecdm.so
drwxr-xr-x 2 root root 1024 Sep 18 22:04 .
CoreELEC:~/.kodi/userdata/addon_data/script.module.inputstreamhelper/cdm #

If you don’t have skipped frames on mentioned sample (Our Planet E1 scenes from 4min to 6min at 1080p with subtitles) then you don’t need to change your libwidevinecdm.so.

1 Like

I have on other shows (Mindhunter season 2), I think those are somehow related.

With my N2 I had no problems with that series with old WV version…

I do have, but maybe I’m hitting another issue than the one the old library fixes.

Do you know how to check the version of libwidevinecdm.so ?
Which version of “libwidevinecdm.so” do you have in “/storage/.kodi/cdm” folder ?

Try to copy libwidevinecdm.so.old to libwidevinecdm.so in /storage/.kodi/cdm folder. That is the way my NF addon works perfect.
At the same time in storage/.kodi/userdata/addon_data/script.module.inputstreamhelper/cdm folder I have the new version which NF addon does not use…

Did you check your temperatures while playing netflix? If you have a GT-King that can be an issue. I experienced it.

yes, I had. The frame rate issue does occur always at the same point in a given video, whatever the time of the day, the uptime of the box or the temperature recorder in the chip.

this is a symlink:
CoreELEC:~/.kodi/cdm # ls -alrt
total 157
drwxr-xr-x 8 root root 1024 Jul 10 19:29 …
lrwxrwxrwx 1 root root 88 Aug 16 20:17 libwidevinecdm.so -> /storage/.kodi/userdata/addon_data/script.module.inputstreamhelper/cdm/libwidevinecdm.so
drwxr-xr-x 3 root root 1024 Sep 6 13:53 .
-rw-r–r-- 1 root root 150514 Sep 20 23:07 recovery.conf.json
drwxr-xr-x 34 root root 3072 Sep 20 23:11 widevine
-rw-r–r-- 1 root root 20 Sep 20 23:11 EDEF8BA9-79D6-4ACE-A3C8-27DCD51D21ED.init
-rw-r–r-- 1 root root 944 Sep 20 23:11 EDEF8BA9-79D6-4ACE-A3C8-27DCD51D21ED.response
-rw-r–r-- 1 root root 1738 Sep 20 23:11 EDEF8BA9-79D6-4ACE-A3C8-27DCD51D21ED.challenge
CoreELEC:~/.kodi/cdm #

the version I have is indeed 4.10.1440.18.

Well, that’s the new version with which I also have frame skips. Old version with which NF works better for me is 4.10.1303.0.