Working USB Wifi/Ethernet adapters for CoreELEC

and which Module i have to block? when i will only use the external Wlan?

There is no single answer to that because it varies depending on what chip you have inside your device.


Could someone please explain to me how to integrate specific driver ?
I’ve successfully builded ng from source, but can’t figure out how to integrate drivers…
I need drivers for RTL8812CU for 4.9 kernel
Found this : and this
I’m a bit lost… I’ve successfully builded above drivers on an ubuntu docker container running on my x96max, but don’t know what to do with the *.ko file…
Thanks in advance :slight_smile:

lsmod shows this.


Module Size Used by
sha1_generic 2492 0
bnep 15079 2
hci_uart 34102 1
bluetooth 372939 23 bnep,hci_uart
6lowpan_iphc 10231 1 bluetooth
wetekdvb 92253 0
dhd 815797 0
ir_lirc_codec 5340 0
lirc_dev 11896 1 ir_lirc_codec
ir_mce_kbd_decoder 5212 0
ir_sanyo_decoder 3115 0
88x2bu 2335472 0
ir_sony_decoder 2649 0
ir_jvc_decoder 2799 0
ir_rc6_decoder 3823 0
ir_rc5_decoder 2735 0
ir_nec_decoder 3615 0
cfg80211 417431 2 dhd,88x2bu
meson_ir 4389 0
mali 224423 5
rc_core 19532 11 lirc_dev,meson_ir,ir_lirc_codec,ir_rc5_decoder,ir_nec_decoder,ir_sony_decoder,ir_mce_kbd_decoder,ir_jvc_decoder,ir_rc6_decoder,ir_sanyo_decoder
wetekplay 117499 1 wetekdvb
dvb_core 105934 2 wetekdvb,wetekplay
wifi_dummy 894 0
amlvideodri 13210 1
videobuf_res 5690 1 amlvideodri
videobuf_core 18248 2 amlvideodri,videobuf_res
videodev 144588 2 amlvideodri
dwc_otg 261556 0
fbcon 40863 0
bitblit 4820 1 fbcon
softcursor 1344 1 bitblit
font 7399 1 fbcon

It’s the internal WIFI Chip of the Wetek Play 2

dhd is what you need to blacklist

1 Like

Hi I bought a few of these thinking they were the same as the ones I had previously bought. They are Cheep about US$4

These did not work automatically when I plugged them in. After a little investigation I found they detect as a 16M usb drive and you need usb_modeswitch to get them to switch to being a wifi adapter.

To make them work install Addons > System Tools
This adds the usb_modeswitch command to coreelec.

Then add the following to the in the config directory


usb_modeswitch -KW -v 0bda -p 1a2b
) &

Reboot and the device will be detected as wlan1

This was using the internal wifi A95X 2.4G


This is using the external adapter 2.4G


This is using the external adapter 5G



Hi, i use TV BOX X96 on last CoreELEC, and test two usb wifi adapters, one SITECOM WL-352 N300, and DNUB-AT1 dual band N300, they just fine and autostart, but work connect to router at 150Mb/s, not 300Mb/s (on pc usb wifi dongles work ok at 300Mb/s), anyone know how to work on 300Mb/s ? 20/40MHz not work good , ?

DNUB-AT1 have 5Ghz , it’s connecting at 300Mb/s but when copy file the dongle disconect and disable from X96. I dont know why…?

Guys is there any usbethernet or usb lte dongle support in CoreELEC? Usbethernet I mean usb lte sticks that gives address over dhcp to the hosts’s usb0 (as an ethernet interface).

I have two USB-LAN adapter, they works well with CE.
Never tried USB mobile stick but I guess it will not work without setting up it properly.

An option to make this work would be to buy a router with a SIM Card slot that has an ethernet out. Something like the below:

oh. it has :smiley: guys you are awesome.

hi, i am looking for a decent working 5ghz antenna wifi. i am reading Chipset Realtek8811AU

Any better driver should i look to use in amlogic-ng?

sorry my english :sweat_smile: thanks

Hi there, I was struggling with this adapter too, I followed your instructions and others I’ve found online and made this little sob work. But I’m connected to my 5gz. and getting really awful speeds. I mean, nearly no difference (or worst) to the onboard adapter of my X96 Mini, like 18/19 Mbps. on Speedtest. Do you have any additional tweak that I could try? Cheers!

PS: I still have to test it on a windows machine, once I get my hands on one.

No sorry, I find 2.4g is better over longer distance or trough walls 5G is better at short distance also it depends on other factors like the number of other routers in the area.

I’ve rtried to work out which Realtek 8812/8822 driver is inlcuded before I buy an adapter. I really need an AC adapter (2.4 ghz actually for range)
Has anyone tried either of these 2 Edup USB wifi adapters

  1. EP-AC1605GS seems to be RTL8812BU
  2. EP-AC1690 seems to be RTL8822BU

The driver source I found which seems relevant is 88x2bu Driver

I looked at the Corelec sources but couldn’t see where the 8822BU driver source came from to see if either or both the above are going to work. Documentation suggests the 8822BU one should … but I have yet to find reports of success

Anyone succeeded with either of these USB AC Wifi adpaters ? Any other recommendations ?


Hey all.
I was testing my lan speed on my M8s II 2/16 tv box with CoreElec 9.2.5 today.

  • With the built-in 100 LAN port of the box I got ~ 95 Mbits/sec

  • With my TP-Link UE300 USB 3.0 to LAN adapter (Realtek 8153 chipset) I got ~ 187 Mbits/sec
    The box only has USB 2.0 ports.

Both my Windows 10 PC and the TV Box are connected to my router with CAT6 UTP cables.
The router has Gbit lan ports. For the tests, I used iperf3. I set my Windows 10 PC as a server and the TV Box as a client.

Are these numbers OK ? I’m asking because I don’t really know what the average numbers are for boxes (and said specs) as the above.

p.s. Isn’t it weird that by reverting the scenario (setting the CoreElec TV Box as a server and the PC as a client) I got quite lower numbers: ~ 65 to 75 Mbits/sec ? The PC has a Gbit ethernet card.

I bought a AX88179 USB Gbit ethernet adapter for my x96Max 2GB ram.
It works out of the box when i plug it in. But when i repoot the box, it does not get detected automatically, I have to un- and replug it to work. Tried with both USB3 aud USB2 ports and both version 2.6.3 and 19.

Any ideas?

I struggled with this for a few weeks and followed some other threads that did not help. It was just a small USB WIFI dongle that was only recognized as a storage device. This worked 100 %. It took me a few minutes to find the “system tools” that added usb_modeswitch, but finally found it in the coreelec repository>program files> system tools.
Thanks for the helpful post!!!

Can you send me a link of the usb adapters you have? I have an x96max that does not connect to the 1000 ethernet network. Only 100 for SSH commands. Thanks

Not sure if it helps, but I use a AX88179 Gigabit Ethernet adapter with my unit without any problems on CE 19.3.
Looks like you can get ones with that chipset at amazon for ~$15. Probably less if you hunt around.