[S922X] Bee-link GT King

After every OTA Android update to start CE you have to use the method which you used for first CE installation, that @Portisch above mentioned.


Hello KOPRajs
I have also GT King Pro , but I cannot boot to CoreELEC. I tried both versions in device trees, but I can boot still only to Android. Also tried with long-press the reset hole and connect the power cord. But then I get only to Andoid Recovery menu. Can you help with this problem ? Many thanks.

Great advice, worked 100%. Thank you.

This is great advice, should be in the FAQ. Everything’s working fine now.

Replaced SD Card and CE is fully working.

I’m running CoreELEC (official): 9.2.1 (Amlogic-ng.arm) on GT-King and I can’t shutdown or reboot properly.
The box disconnects the ssh session, the screen turns black but it stays with the green leds and never really turns off or reboots.
To turn it on again I have to disconnect the power and connect again. The remote doesn’t work either.
This happens if I shutdown or reboot on Kodi UI or using a ssh terminal command.
The Suspend option on Kodi does work, however (the led turns red), and I can resume pressing the remote power button.

– Any idea why the shutdown doesn’t work?
I’m booting from SD card and I have a mounted partition to eMMC. Can this be related?

I’ve installed the CoreELEC BL301 Wake-Up feature [inject_bl301] but it didn’t change anything.

My config.ini is
decode_type=‘0x0’ # NEC

Upload a link on your logs

1 Like

Thank you.

Here are the logs:
From Kodi: http://ix.io/24mK
From ssh dmesg | paste : http://ix.io/24mL

I collected them after I tried to turn off using both the remote and Kodi (that doesn’t wok properly like I mentioned). Then I had to turn off the power and turn it on again on the electric cord since powering on from the remote doesn’t work either.

You dont need any injection. Just use remote.conf file in CE. Works good.

Should I remove the Injection? How?
Before that I had the same problem - I can’t shutdown or reboot properly. The screen turns black but the box stays with the green leds and never really turns off or reboots.

What remote.conf should I use?

Here is mine. remote.conf (1.5 KB)

1 Like

Thank you. It’s exactly the same as another one I’ve found here.
I’ve tried it before with no success.

I have two problems:

1 - The box doesn’t shutdown or reboot properly. The screen turns black and disconnects but the box stays with the green leds and never really turns off or reboots.

2 - The remote doesn’t activate the shutdown on kodi.
However if I suspend the box then the leds go red and the remote works to wake it. I don’t know if it also works from a shutdown state because I can’t put the box on such state.

Logs (before the remote.conf but it didn’t change the behaviour):
From Kodi: http://ix.io/24mK
From ssh dmesg | paste : http://ix.io/24mL

I have Stock android rom from beelink, no any bl injection, CE on usb pendrive. With this, the box working good, totally power off, no led light.

From your logs it looks like clean start…
What Android firmware does your box have?
Try to comment decode_type, remotewakeupmask, wol values. They are the same as default one
So you can change only remotewakeup code. Is it correct? Does power button works for shutdown?

I have firmware 906P0.
SN: B922HQ…
I installed CE rev A on SD card because it didn’t boot with rev B.

Before I had the original config.ini with no changes but then I tried everything I’ve read trying to solve the problem.

The power button on remote doesn’t work for shutdown. It only works to resume from the suspend state.
I’m not even trying to solve the remote problem now - first I would like to be able to shutdown/reboot the box properly.
If not I’ll have to educate myself to just suspend the box.

If it doesn’t work for power off then it looks like you have wrong code…
Or use instruction to find correct key How to configure IR remote control
Enable debug mode, press power button, disable debug mode and collect log

With the following keymap file now the power button shutdowns Kodi

# table gtkingboxkeymap, type: NEC
0x8051 KEY_POWER

However the behavior is the same as if I select the option on the UI: The box turns off the screen and the network but the leds are still on (green) and the only way to restart is to turn off the power and then turn on again.

PS: I discovered that if I unmount the emmc file system before shutdown (I’m mounting on startup doing something like this: How to run CoreElec on internal memory eMMC on NG boxes (S905X2, S922X) having full operating Android system too) then when I shutdown the box goes to sleep - I say it goes to sleep and not turns off because the led lights are dark red, not completely off, but perhaps that’s just how it works.
Problem is that with the key map the remote does not wake it.


  • I can use the remote to turn off Kodi (using the keymap) or to wake the box (using config.ini), but not both.
  • Box does not shutdown if a mount to emmc exists (I have to automate the umount on shutdown.sh).
  • The box never completely turns the leds light off - they’re red on shutdown? / suspend.

You are using a tool that wasn’t provided by Team CE. Please test your device running from SD or at least use the official tool ceemmc. This isn’t supported on the king but I can guarantee that it’s fully functional.

Sorry but I don’t understand. Which tool am I using that I shouldn’t?

  • Is it possible to shutdown and also wake the box from the remote?
  • When the box shut downs how should the leds be? (The eyes on the skull). Dark red or completely off?

Than you.

If you followed what is discussed in that topic you’re on your own. My eyes stay red.