How to configure IR remote control

IR remote controls can be configured in 1 of 2 ways in CoreELEC, both are detailed in this guide below.

meson-ir
meson-ir allows you to use almost any IR remote controller to control your device.

CoreELEC uses meson-ir by default and our builds come with a limited selection of IR remote configurations for devices built in.

If your remote does not work then you will need to follow the below instructions to create a config and get it working.

Firstly you must SSH into your device and then Kodi and eventlircd services must be stopped.

systemctl stop kodi
systemctl stop eventlircd

Next you need to run ir-keytable to scan for remote codes.

ir-keytable -p NEC,RC-5,RC-6,JVC,SONY -t

Start to press all of the buttons on your remote and make a note of each scan code in notepad on your computer.

Now you need to create your configuration, an example can be seen here. Don’t delete 1st line, only name and protocol could be modified in it. A list of functions can be found here.

For CoreELEC 19 use this example.

When you have created your map file it needs to be saved in the following location.

/storage/.config/rc_keymaps/YOURMAPNAME

or for CoreELEC 19

/storage/.config/rc_keymaps/YOURMAPNAME.toml

You must also create the following file /storage/.config/rc_maps.cfg with the following contents.

meson-ir * YOURMAPNAME

or for CoreELEC 19

meson-ir * YOURMAPNAME.toml

Now you must load your config and start Kodi and eventlircd back up to test your changes.

ir-keytable -a /storage/.config/rc_maps.cfg -s rc0
systemctl start eventlircd
systemctl start kodi

If your config works and you are happy with it then you are not required to do anything further and it will be loaded automatically when rebooting/powering on your device.

Pre-made remote control configurations can be found here.

CoreELEC 19 change
For CoreELEC 19 YOURMAPNAME needs extension .toml. The whole filename is then YOURMAPNAME.toml. So instead to use only YOURMAPNAME it has to be YOURMAPNAME.toml.

Please ensure your YOURMAPNAME.toml does meet the .toml file structure including the sections:

[[protocols]]
[protocols.scancodes]

But old format of the keymaps from CoreELEC 9 are still compatible with CoreELEC 19. But they must not have .toml extension to work properly.

amremote
Many of you will be most familiar with this method, amremote typically gives a much better user experience with the bundled remotes with generic devices.

To use an amremote configuration simply copy your remote.conf file to either the root folder of your SD card / USB flash drive or to /storage/.config/remote.conf.

NOTE: after the first time you boot your device with an amremote configuration it will automatically reboot whilst modifications are made to your dtb to enable amremote.

You can change back to meson-ir at any time by simply removing the remote.conf file and rebooting.

14 Likes
How to find code of a key to update remote.conf
IR controller doesn't work after configuration
Amlogic S905X3, S905Y3, S905D3 thread
(S912) H96 Pro+ Black Board - Trouble Remote Power ON
Help installing CoreELEC 9.2.2 on T95Z Plus (Amlogic S912)
Help with the remote.conf
Minix Neo U1 device tree - remote control
Tanix TX9S
No response to ir-keytable
A95X -R1 / S905W issue
Remote control X96 mini
Nightly builds
Keymap.xml and meson-ir
CoreELEC 8.99.2
CoreELEC 9.0.0
Problem delay remote controller KIpro s905x
8.90.5 - Mini M8S II - remote controller doesn't work
OTT TV-BOX T95M -> Which DTB for VFD Use / Remote Control
How to manipulate remote files?
Change remote keymap
Notice on updating from LibreELEC builds
Support added for S905X2, S922X and A311D!
Device tree gxbb_p200_2G_1Gbit failure on Leia Final
[S922X] Bee-link GT King
X96 Max - LCD & Remote
Config for enabling Minix A2 poweroff stops working after reboot
Odroid N2+ built-in IR receiver not working [Solved]
Remote for Mini M8 II,X96Air CoreELEC 19.3-Matrix
Remote controller not working with crazycat drivers
Increase Playbackspeed with remote
CEC stop working correctly After .3 update
Android box h96 pro plus does not work on the remote control
Understanding RC install; need map table
Tvheadend htsp client no signal message
Understanding RC install; need map table
[S922X] X88 King
Remote for Odroid N2
Update to 8.90.2 Tanix TX3 Mini
Ir_keytable only working for button working
Whats the scheme for remotes on 8.90.2
NEW Repo for Remote files (Thanks to Betatester)
[S905X2] Setup a Ugoos X2 Cube with CoreELEC 9.2.2? Power on by USB keyboard?
How to execute a linux command by pressing a remote key?
T95x2 remote config trouble (s905x2)
Power on/off with minix neo a2 remote with odroid N2
Ugoos X4 Pro with Amlogic S905X4
Denon and Panasonic Non-supported remotes
CoreElec freezes on welcome screen
Xbox Media Remote
Wetek Pro remote
Question about 3rd party remotes
Remote control mini mxiii
How can I change the power OFF code ? (+ how to reset meson-ir ?)
9.2.4.2 Discussion
Mecool KM9 PRO - amremote config file not updating DTB
Khadas VIM3L IR and CE 19.X
Help to power on with Odroid-N2
[S905X3] X96Air_P2/P3 4/32GB 1Gbit Lan (How to config)
Bl301 injection, problems, help,
IR does not work: /sys/class/rc/: No such file or directory
Nexbox A95X (1gb) power-on from IR remote?
Coreelec does not boot in X96 mini
CoreELEC 19.1-Matrix_rc1 Discussion
X96 (S905X), power on by IR remote not working
[Solved] VIM3L problem with ir remote on CoreELEC 9.2.2
[S922X] X88 King
ABOX A1 Max 2GB
NEW Repo for Remote files (Thanks to Betatester)
NEW Repo for Remote files (Thanks to Betatester)
NEW Repo for Remote files (Thanks to Betatester)
Is the MCE usb receiver supported?
NEW Repo for Remote files (Thanks to Betatester)
NEW Repo for Remote files (Thanks to Betatester)
Updating M8S PRO+ S905X or not - beginner questions
(solved) After update to 8.95.6 Media Center Extention (Logitech Harmony) don't work
Trivial Button Issue Mapping
No response to ir-keytable
NEW Repo for Remote files (Thanks to Betatester)
X96 mini remote went retrograde after 19.1
Switching back from AMREMOTE to MESON-IR
IR Remote not working until ir-keytable gets executed
CoreElec freezes on welcome screen
Need help wit a RC Remote
No working remote control on Mecool KI Pro (Amlogic-ng)
19.0-Matrix Discussion
No response to ir-keytable
TV control using TV Box remote
IR Remote config creation
Problem with activating Remote.conf
Problem with activating Remote.conf
Support added for S905X2, S922X and A311D!
[S922X] X88 King
Sunvell T95X: Stuck at Setup Wizard
Sunvell T95X: Stuck at Setup Wizard
The number key of sony TV remote control does not work in coreelec
What remote is enabled by default in rc_maps.cfg
TX5 PRO remote configuration differences between Coreelec releases
Minix U1 supplied remote stopped working in 8.95.5
Logitech Harmony 650 responsiveness problem
[SOLVED] Which keycodes are available to use? (KEY_PROG1, KEY_F13 etc don't work)
NEW Repo for Remote files (Thanks to Betatester)
CoreELEC 8.95.0 release
Error "Error in mount_storage: " after first start